What’s Vulnerable › Vulnerabilities
CVE-2026-32687: SQL injection via channel name in Postgrex.Notifications.listen/3 and unlisten/3
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-12 · updated 2026-07-24
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in elixir-ecto postgrex ('Elixir.Postgrex.Notifications' module) allows SQL Injection. The channel argument passed to 'Elixir.Postgrex.Notifications':listen/3 and 'Elixir.Postgrex.Notifications':unlisten/3 is interpolated directly into LISTEN "..." / UNLISTEN "..." SQL statements without escaping the " character. An attacker who can influence the channel name can inject a " to break out of the quoted identifier and append arbitrary SQL. Because the notifications connection uses the PostgreSQL simple query protocol, multi-statement payloads are accepted, allowing DDL and DML commands to be chained (e.g. ; DROP TABLE ...; --). The same unsanitized interpolation also occurs in handle_connect/1 when replaying LISTEN commands after a reconnect. This vulnerability is associated with program file lib/postgrex/notifications.ex and program routines 'Elixir.Postgrex.Notifications':listen/3, 'Elixir.Postgrex.Notifications':unlisten/3, 'Elixir.Postgrex.Notifications':handle_connect/1. This issue affects postgrex: from 0.16.0 before 0.22.2.
Affected products
- elixir-ecto postgrex: from 0.16.0 before 0.22.0 — fixed in 0.22.0
How to fix
Upgrade to a fixed version: elixir-ecto postgrex 0.22.0. Check the vendor advisory for mitigations.
References
- https://cna.erlef.org/cves/CVE-2026-32687.html
- https://github.com/elixir-ecto/ecto/security/advisories/GHSA-r73h-97w8-m54h
- https://github.com/elixir-ecto/postgrex/commit/7cdedbd4316bb65f82e6a9a4f922c0ac491cb770
- https://osv.dev/vulnerability/EEF-CVE-2026-32687
Get alerted when CVE-2026-32687 or the next vulnerability affects your stack