What’s Vulnerable › Vulnerabilities
CVE-2026-32705: PX4 autopilot BST Device Name Length Can Overflow Driver Buffer
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-16 · updated 2026-06-17
- Weakness: CWE-121
Description
PX4 autopilot is a flight control solution for drones. Prior to 1.17.0-rc2, the BST telemetry probe writes a string terminator using a device-provided length without bounds. A malicious BST device can report an oversized dev_name_len, causing a stack overflow in the driver and crashing the task (or enabling code execution). This vulnerability is fixed in 1.17.0-rc2.
Affected products
- PX4-Autopilot: before 1.17.0; 1.17.0-alpha1, 1.17.0-beta1, 1.17.0-rc1 — fixed in 1.17.0
How to fix
Upgrade to a fixed version: PX4-Autopilot 1.17.0. Check the vendor advisory for mitigations.
References
- https://github.com/PX4/PX4-Autopilot/security/advisories/GHSA-79mp-34pp-2f3f
- https://github.com/PX4/PX4-Autopilot/security/advisories/GHSA-79mp-34pp-2f3f
Get alerted when CVE-2026-32705 or the next vulnerability affects your stack