What’s Vulnerable › Vulnerabilities
CVE-2026-32706: PX4 autopilot has a global buffer overflow in crsf_rc via oversized variable-length known packet
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-16 · updated 2026-06-17
- Weakness: CWE-120
Description
PX4 autopilot is a flight control solution for drones. Prior to 1.17.0-rc2, The crsf_rc parser accepts an oversized variable-length known packet and copies it into a fixed 64-byte global buffer without a bounds check. In deployments where crsf_rc is enabled on a CRSF serial port, an adjacent/raw-serial attacker can trigger memory corruption and crash PX4. This vulnerability is fixed in 1.17.0-rc2.
Affected products
- PX4-Autopilot: before 1.17.0; 1.17.0-alpha1, 1.17.0-beta1, 1.17.0-rc1 — fixed in 1.17.0
How to fix
Upgrade to a fixed version: PX4-Autopilot 1.17.0. Check the vendor advisory for mitigations.
References
- https://github.com/PX4/PX4-Autopilot/security/advisories/GHSA-mqgj-hh4g-fg5p
- https://github.com/PX4/PX4-Autopilot/security/advisories/GHSA-mqgj-hh4g-fg5p
Get alerted when CVE-2026-32706 or the next vulnerability affects your stack