What’s Vulnerable › Vulnerabilities
CVE-2026-32707: PX4 autopilot has a stack buffer overflow in tattu_can due to unbounded memcpy in frame assembly loop
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-16 · updated 2026-06-17
- Weakness: CWE-121
Description
PX4 autopilot is a flight control solution for drones. Prior to 1.17.0-rc2, tattu_can contains an unbounded memcpy in its multi-frame assembly loop, allowing stack memory overwrite when crafted CAN frames are processed. In deployments where tattu_can is enabled and running, a CAN-injection-capable attacker can trigger a crash (DoS) and memory corruption. This vulnerability is fixed in 1.17.0-rc2.
Affected products
- PX4-Autopilot: before 1.17.0; 1.17.0-alpha1, 1.17.0-beta1, 1.17.0-rc1 — fixed in 1.17.0
How to fix
Upgrade to a fixed version: PX4-Autopilot 1.17.0. Check the vendor advisory for mitigations.
References
- https://github.com/PX4/PX4-Autopilot/security/advisories/GHSA-wxwm-xmx9-hr32
- https://github.com/PX4/PX4-Autopilot/security/advisories/GHSA-wxwm-xmx9-hr32
Get alerted when CVE-2026-32707 or the next vulnerability affects your stack