What’s Vulnerable › Vulnerabilities
CVE-2026-32710: Heap-based Buffer Overflow in MariaDB
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-20 · updated 2026-06-17
- Weakness: CWE-122
Description
MariaDB server is a community developed fork of MySQL server. An authenticated user can crash MariaDB versions 11.4 before 11.4.10 and 11.8 before 11.8.6 via a bug in JSON_SCHEMA_VALID() function. Under certain conditions it might be possible to turn the crash into a remote code execution. These conditions require tight control over memory layout which is generally only attainable in a lab environment. This issue is fixed in MariaDB 11.4.10, MariaDB 11.8.6, and MariaDB 12.2.2.
Affected products
- MariaDB: from 11.4.1 before 11.4.10; from 11.8.1 before 11.8.6; 12.1.2 — fixed in 11.4.10, 11.8.6
How to fix
Upgrade to a fixed version: MariaDB 11.4.10, 11.8.6. Check the vendor advisory for mitigations.
References
- https://github.com/MariaDB/server/security/advisories/GHSA-4rj5-2227-9wgc
- https://jira.mariadb.org/browse/MDEV-38356
Get alerted when CVE-2026-32710 or the next vulnerability affects your stack