What’s Vulnerable › Vulnerabilities

CVE-2026-32721: LuCI luci-mod-network: Possible XSS attack in WiFi scan on Joining Wireless Client modal

Description

LuCI is the OpenWrt Configuration Interface. Versions prior to both 24.10.5 and 25.12.0, contain a stored XSS vulnerability in the wireless scan modal, where SSID values from scan results are rendered as raw HTML without any sanitization. The wireless.js file in the luci-mod-network package passes SSIDs via a template literal to dom.append(), which processes them through innerHTML, allowing an attacker to craft a malicious SSID containing arbitrary HTML/JavaScript. Exploitation requires the user to actively open the wireless scan modal (e.g., to connect to a Wi-Fi access point or survey nearby channels), and only affects OpenWrt versions newer than 23.05/22.03 up to the patched releases (24.10.6 and 25.12.1). The issue has been fixed in version LuCI 26.072.65753~068150b.

Affected products

How to fix

Upgrade to a fixed version: openwrt luci 26.072.65753-068150b; openwrt 24.10.6, 25.12.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-32721 or the next vulnerability affects your stack