What’s Vulnerable › Vulnerabilities
CVE-2026-32730: ApostropheCMS MFA/TOTP Bypass via Incorrect MongoDB Query in Bearer Token Middleware
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-18 · updated 2026-06-17
- Weakness: CWE-287
Description
ApostropheCMS is an open-source content management framework. Prior to version 4.28.0, the bearer token authentication middleware in `@apostrophecms/express/index.js` (lines 386-389) contains an incorrect MongoDB query that allows incomplete login tokens — where the password was verified but TOTP/MFA requirements were NOT — to be used as fully authenticated bearer tokens. This completely bypasses multi-factor authentication for any ApostropheCMS deployment using `@apostrophecms/login-totp` or any custom `afterPasswordVerified` login requirement. Version 4.28.0 fixes the issue.
Affected products
- apostrophecms apostrophe: before 4.28.0 — fixed in 4.28.0
How to fix
Upgrade to a fixed version: apostrophecms apostrophe 4.28.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-32730 or the next vulnerability affects your stack