What’s Vulnerable › Vulnerabilities
CVE-2026-32732: XSS in @leanprover/unicode-input-component
- Severity: none (CVSS 0.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-16 · updated 2026-06-17
- Weakness: CWE-80
Description
Lean 4 VS Code Extension is a Visual Studio Code extension for the Lean 4 proof assistant. Projects that use @leanprover/unicode-input-component are vulnerable to an XSS exploit in 0.1.9 of the package and lower. The component re-inserted text in the input element back into the input element as unescaped HTML. The issue has been resolved in 0.2.0.
Affected products
- leanprover vscode-lean4: before 0.2.0
References
- https://github.com/leanprover/vscode-lean4/pull/735
- https://github.com/leanprover/vscode-lean4/security/advisories/GHSA-6ggm-pwr9-r5h2
- https://leanprover.zulipchat.com/#narrow/channel/113488-general/topic/weird.20behavior.20in.20loogle.20searchbar/near/578502003
Get alerted when CVE-2026-32732 or the next vulnerability affects your stack