What’s Vulnerable › Vulnerabilities
CVE-2026-32742: Parse Server session creation endpoint allows overwriting server-generated session fields
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-18 · updated 2026-06-17
- Weakness: CWE-915
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.17 and 8.6.42, an authenticated user can overwrite server-generated session fields (`sessionToken`, `expiresAt`, `createdWith`) when creating a session object via `POST /classes/_Session`. This allows bypassing the server's session expiration policy by setting an arbitrary far-future expiration date. It also allows setting a predictable session token value. Starting in version 9.6.0-alpha.17 and 8.6.42, the session creation endpoint filters out server-generated fields from user-supplied data, preventing them from being overwritten. As a workaround, add a `beforeSave` trigger on the `_Session` class to validate and reject or strip any user-supplied values for `sessionToken`, `expiresAt`, and `createdWith`.
Affected products
- parse-community parse-server: before 8.6.42; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha10, 9.6.0-alpha11, 9.6.0-alpha12, 9.6.0-alpha13, 9.6.0-alpha14 (+9) — fixed in 8.6.42, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.42, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/pull/10195
- https://github.com/parse-community/parse-server/pull/10196
- https://github.com/parse-community/parse-server/security/advisories/GHSA-5v7g-9h8f-8pgg
Get alerted when CVE-2026-32742 or the next vulnerability affects your stack