What’s Vulnerable › Vulnerabilities
CVE-2026-32770: Parse Server: LiveQuery subscription with invalid regular expression crashes server
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-18 · updated 2026-06-17
- Weakness: CWE-248
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.19 and 8.6.43, a remote attacker can crash the Parse Server by subscribing to a LiveQuery with an invalid regular expression pattern. The server process terminates when the invalid pattern reaches the regex engine during subscription matching, causing denial of service for all connected clients. The fix in 9.6.0-alpha.19 and 8.6.43 validates regular expression patterns at subscription time, rejecting invalid patterns before they are stored. Additionally, a defense-in-depth try-catch prevents any subscription matching error from crashing the server process. As a workaround, disable LiveQuery if it is not needed.
Affected products
- parse-community parse-server: before 8.6.43; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha10, 9.6.0-alpha11, 9.6.0-alpha12, 9.6.0-alpha13, 9.6.0-alpha14 (+12) — fixed in 8.6.43, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.43, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/pull/10197
- https://github.com/parse-community/parse-server/pull/10199
- https://github.com/parse-community/parse-server/security/advisories/GHSA-827p-g5x5-h86c
Get alerted when CVE-2026-32770 or the next vulnerability affects your stack