What’s Vulnerable › Vulnerabilities
CVE-2026-32794: Apache Airflow Provider for Databricks: TLS Certificate Verification Disabled in Databricks Provider K8s Token Exchange
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-30 · updated 2026-06-17
- Weakness: CWE-295
Description
Improper Certificate Validation vulnerability in Apache Airflow Provider for Databricks. Provider code did not validate certificates for connections to Databricks back-end which could result in a man-of-a-middle attack that traffic is intercepted and manipulated or credentials exfiltrated w/o notice. This issue affects Apache Airflow Provider for Databricks: from 1.10.0 before 1.12.0. Users are recommended to upgrade to version 1.12.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Airflow Provider for Databricks: from 1.10.0 before 1.12.0 — fixed in 1.12.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow Provider for Databricks 1.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/63704
- https://lists.apache.org/thread/hn17yqsgsdtl81llvhf80rkp53hnz5nb
- http://www.openwall.com/lists/oss-security/2026/03/30/9
Get alerted when CVE-2026-32794 or the next vulnerability affects your stack