What’s Vulnerable › Vulnerabilities
CVE-2026-32829: lz4_flex: Decompression can leak information from uninitialized memory or reused output buffer
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-20 · updated 2026-09-17
- Weakness: CWE-201
Description
lz4_flex is a pure Rust implementation of LZ4 compression/decompression. In versions 0.11.5 and below, and 0.12.0, decompressing invalid LZ4 data can leak sensitive information from uninitialized memory or from previous decompression operations. The library fails to properly validate offset values during LZ4 "match copy operations," allowing out-of-bounds reads from the output buffer. The block-based API functions (`decompress_into`, `decompress_into_with_dict`, and others when `safe-decode` is disabled) are affected, while all frame APIs are unaffected. The impact is potential exposure of sensitive data and secrets through crafted or malformed LZ4 input. This issue has been fixed in versions 0.11.6 and 0.12.1.
Affected products
- PSeitz lz4_flex: before 0.11.6; 0.12.0 — fixed in 0.11.6
How to fix
Upgrade to a fixed version: PSeitz lz4_flex 0.11.6. Check the vendor advisory for mitigations.
References
- https://github.com/PSeitz/lz4_flex/commit/055502ee5d297ecd6bf448ac91c055c7f6df9b6d
- https://github.com/PSeitz/lz4_flex/security/advisories/GHSA-vvp9-7p8x-rfvv
- https://rustsec.org/advisories/RUSTSEC-2026-0041.html
- https://access.redhat.com/errata/RHSA-2026:11800
- https://access.redhat.com/errata/RHSA-2026:16354
- https://access.redhat.com/errata/RHSA-2026:19712
- https://access.redhat.com/errata/RHSA-2026:22862
- https://access.redhat.com/security/cve/CVE-2026-32829
- https://bugzilla.redhat.com/show_bug.cgi?id=2448271
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-32829.json
Get alerted when CVE-2026-32829 or the next vulnerability affects your stack