What’s Vulnerable › Vulnerabilities
CVE-2026-32878: Parse Server vulnerable to schema poisoning via prototype pollution in deep copy
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-18 · updated 2026-06-17
- Weakness: CWE-1321
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.20 and 8.6.44, an attacker can bypass the default request keyword denylist protection and the class-level permission for adding fields by sending a crafted request that exploits prototype pollution in the deep copy mechanism. This allows injecting fields into class schemas that have field addition locked down, and can cause permanent schema type conflicts that cannot be resolved even with the master key. In 9.6.0-alpha.20 and 8.6.44, the vulnerable third-party deep copy library has been replaced with a built-in deep clone mechanism that handles prototype properties safely, allowing the existing denylist check to correctly detect and reject the prohibited keyword. No known workarounds are available.
Affected products
- parse-community parse-server: before 8.6.44; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha10, 9.6.0-alpha11, 9.6.0-alpha12, 9.6.0-alpha13, 9.6.0-alpha14 (+13) — fixed in 8.6.44, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.44, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/pull/10200
- https://github.com/parse-community/parse-server/pull/10201
- https://github.com/parse-community/parse-server/security/advisories/GHSA-9ccr-fpp6-78qf
Get alerted when CVE-2026-32878 or the next vulnerability affects your stack