What’s Vulnerable › Vulnerabilities
CVE-2026-32881: ewe has an Overly Permissive List of Allowed Inputs
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-20 · updated 2026-06-17
- Weakness: CWE-183
Description
ewe is a Gleam web server. ewe is a Gleam web server. Versions 0.6.0 through 3.0.4 are vulnerable to authentication bypass or spoofed proxy-trust headers. Chunked transfer encoding trailer handling merges declared trailer fields into req.headers after body parsing, but the denylist only blocks 9 header names. A malicious client can exploit this by declaring these headers in the Trailer field and appending them after the final chunk, causing request.set_header to overwrite legitimate values (e.g., those set by a reverse proxy). This enables attackers to forge authentication credentials, hijack sessions, bypass IP-based rate limiting, or spoof proxy-trust headers in any downstream middleware that reads headers after ewe.read_body is called. This issue has been fixed in version 3.0.5.
Affected products
- vshakitskiy ewe: before 3.0.5 — fixed in 3.0.5
How to fix
Upgrade to a fixed version: vshakitskiy ewe 3.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/vshakitskiy/ewe/commit/07dcfd2135fc95f38c17a9d030de3d7efee1ee39
- https://github.com/vshakitskiy/ewe/commit/94ab6e7bf7293e987ae98b4daa51ea131c2671ba
- https://github.com/vshakitskiy/ewe/releases/tag/v3.0.5
- https://github.com/vshakitskiy/ewe/security/advisories/GHSA-9w88-79f8-m3vp
Get alerted when CVE-2026-32881 or the next vulnerability affects your stack