What’s Vulnerable › Vulnerabilities
CVE-2026-32906: OpenClaw < 2026.5.12 - Privilege Escalation in Slack Plugin Approvals via Exec Approver Gate
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-29 · updated 2026-07-21
- Weakness: CWE-863
Description
OpenClaw before 2026.5.12 contains a privilege escalation vulnerability in Slack plugin approvals that allows exec-authorized users to resolve plugin approvals through the exec approver gate. Attackers with limited exec approval permissions can bypass intended approval splits to approve plugin actions outside operator configuration.
Affected products
- OpenClaw: before 2026.5.12 — fixed in 2026.5.12
How to fix
Upgrade to a fixed version: OpenClaw 2026.5.12. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-wv26-j37q-2g7p
- https://www.vulncheck.com/advisories/openclaw-privilege-escalation-in-slack-plugin-approvals-via-exec-approver-gate
Get alerted when CVE-2026-32906 or the next vulnerability affects your stack