What’s Vulnerable › Vulnerabilities
CVE-2026-32914: OpenClaw < 2026.3.12 - Insufficient Access Control in /config and /debug Endpoints
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-29 · updated 2026-06-17
- Weakness: CWE-863
Description
OpenClaw before 2026.3.12 contains an insufficient access control vulnerability in the /config and /debug command handlers that allows command-authorized non-owners to access owner-only surfaces. Attackers with command authorization can read or modify privileged configuration settings restricted to owners by exploiting missing owner-level permission checks.
Affected products
- OpenClaw: before 2026.3.12 — fixed in 2026.3.12
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.12. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-r7vr-gr74-94p8
- https://www.vulncheck.com/advisories/openclaw-insufficient-access-control-in-config-and-debug-endpoints
Get alerted when CVE-2026-32914 or the next vulnerability affects your stack