What’s Vulnerable › Vulnerabilities
CVE-2026-32920: OpenClaw < 2026.3.12 - Arbitrary Code Execution via Auto-Discovery of Workspace Plugins
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-07-25
- Weakness: CWE-829
Description
OpenClaw before 2026.3.12 automatically discovers and loads plugins from .OpenClaw/extensions/ without explicit trust verification, allowing arbitrary code execution. Attackers can execute malicious code by including crafted workspace plugins in cloned repositories that execute when users run OpenClaw from the directory.
Affected products
- OpenClaw: before 2026.3.12 — fixed in 2026.3.12
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.12. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-99qw-6mr3-36qr
- https://www.vulncheck.com/advisories/openclaw-arbitrary-code-execution-via-auto-discovery-of-workspace-plugins
Get alerted when CVE-2026-32920 or the next vulnerability affects your stack