What’s Vulnerable › Vulnerabilities

CVE-2026-32935: phpseclib's AES-CBC unpadding susceptible to padding oracle timing attack

Description

phpseclib is a PHP secure communications library. Projects using versions 0.1.1 through 1.0.26, 2.0.0 through 2.0.51, and 3.0.0 through 3.0.49 are vulnerable to a to padding oracle timing attack when using AES in CBC mode. This issue has been fixed in versions 1.0.27, 2.0.52 and 3.0.50.

Affected products

How to fix

Upgrade to a fixed version: phpseclib 1.0.27, 2.0.52, 3.0.50; Packagist Phpseclib/Phpseclib 3.0.50, 2.0.52, 1.0.27. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-32935 or the next vulnerability affects your stack