What’s Vulnerable › Vulnerabilities
CVE-2026-32939: DataEase is Vulnerable to H2 JDBC RCE Bypass
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-20 · updated 2026-06-17
- Weakness: CWE-178
Description
DataEase is an open source data visualization analysis tool. Versions 2.10.19 and below have inconsistent Locale handling between the JDBC URL validation logic and the H2 JDBC engine's internal parsing. DataEase uses String.toUpperCase() without specifying an explicit Locale, causing its security checks to rely on the JVM's default runtime locale, while H2 JDBC always normalizes URLs using Locale.ENGLISH. In Turkish locale environments (tr_TR), Java converts the lowercase letter i to İ (dotted capital I) instead of the standard I, so a malicious parameter like iNIT becomes İNIT in DataEase's filter (bypassing its blacklist) while H2 still correctly interprets it as INIT. This discrepancy allows attackers to smuggle dangerous JDBC parameters past DataEase's security validation, and the issue has been confirmed as exploitable in real DataEase deployment scenarios running under affected regional settings. The issue has been fixed in version 2.10.20.
Affected products
- dataease: before 2.10.20 — fixed in 2.10.20
How to fix
Upgrade to a fixed version: dataease 2.10.20. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/commit/8f1c21834a620d37dafb3fa24605c059d0a5b80d
- https://github.com/dataease/dataease/releases/tag/v2.10.20
- https://github.com/dataease/dataease/security/advisories/GHSA-pj7p-3m49-52qq
Get alerted when CVE-2026-32939 or the next vulnerability affects your stack