What’s Vulnerable › Vulnerabilities
CVE-2026-32944: Parse Server crash via deeply nested query condition operators
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-18 · updated 2026-06-17
- Weakness: CWE-674
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.21 and 8.6.45, an unauthenticated attacker can crash the Parse Server process by sending a single request with deeply nested query condition operators. This terminates the server and denies service to all connected clients. Starting in version 9.6.0-alpha.21 and 8.6.45, a depth limit for query condition operator nesting has been added via the `requestComplexity.queryDepth` server option. The option is disabled by default to avoid a breaking change. To mitigate, upgrade and set the option to a value appropriate for your app. No known workarounds are available.
Affected products
- parse-community parse-server: before 8.6.45; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha10, 9.6.0-alpha11, 9.6.0-alpha12, 9.6.0-alpha13, 9.6.0-alpha14 (+14) — fixed in 8.6.45, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.45, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/pull/10202
- https://github.com/parse-community/parse-server/pull/10203
- https://github.com/parse-community/parse-server/security/advisories/GHSA-9xp9-j92r-p88v
Get alerted when CVE-2026-32944 or the next vulnerability affects your stack