What’s Vulnerable › Vulnerabilities
CVE-2026-32945: PJSIP is vulnerable to Heap-based Buffer Overflow through DNS parser
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-20 · updated 2026-06-17
- Weakness: CWE-122
Description
PJSIP is a free and open source multimedia communication library written in C. Versions 2.16 and below have a Heap-based Buffer Overflowvulnerability in the DNS parser's name length handler. Thisimpacts applications using PJSIP's built-in DNS resolver, such as those configured with pjsua_config.nameserver or UaConfig.nameserver in PJSUA/PJSUA2. It does not affect users who rely on the OS resolver (e.g., getaddrinfo()) by not configuring a nameserver, or those using an external resolver via pjsip_resolver_set_ext_resolver(). This issue is fixed in version 2.17. For users unable to upgrade, a workaround is to disable DNS resolution in the PJSIP config (by setting nameserver_count to zero) or to use an external resolver implementation instead.
Affected products
- Pjsip: before 2.17 — fixed in 2.17
How to fix
Upgrade to a fixed version: Pjsip 2.17. Check the vendor advisory for mitigations.
References
- https://github.com/pjsip/pjproject/commit/5311aee398ae9d623829a6bad7b679a193c9e199
- https://github.com/pjsip/pjproject/security/advisories/GHSA-jr2p-p2w4-rr9q
Get alerted when CVE-2026-32945 or the next vulnerability affects your stack