What’s Vulnerable › Vulnerabilities
CVE-2026-32954: ERP has a possibility SQL Injection vulnerability due to missing validation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-20 · updated 2026-06-17
- Weakness: CWE-89
Description
ERP is a free and open source Enterprise Resource Planning tool. In versions prior to 16.8.0 and 15.100.0, certain endpoints were vulnerable to time-based and boolean-based blind SQL injection due to insufficient parameter validation, allowing attackers to infer database information. This issue has been fixed in versions 15.100.0 and 16.8.0.
Affected products
- frappe erpnext: before 15.100.0; from 16.0.0 before 16.8.0 — fixed in 15.100.0, 16.8.0
How to fix
Upgrade to a fixed version: frappe erpnext 15.100.0, 16.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/erpnext/releases/tag/v15.100.0
- https://github.com/frappe/erpnext/releases/tag/v16.8.0
- https://github.com/frappe/erpnext/security/advisories/GHSA-j669-ghv2-gmqg
Get alerted when CVE-2026-32954 or the next vulnerability affects your stack