What’s Vulnerable › Vulnerabilities
CVE-2026-32971: OpenClaw < 2026.3.11 - Node-Host Approval UI Mismatch Allows Execution of Unintended Commands
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-07-25
- Weakness: CWE-451
Description
OpenClaw before 2026.3.11 contains an approval-integrity vulnerability in node-host system.run approvals that displays extracted shell payloads instead of the executed argv. Attackers can place wrapper binaries and induce wrapper-shaped commands to execute local code after operators approve misleading command text.
Affected products
- OpenClaw: before 2026.3.11 — fixed in 2026.3.11
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.11. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-rw39-5899-8mxp
- https://www.vulncheck.com/advisories/openclaw-node-host-approval-ui-mismatch-allows-execution-of-unintended-commands
Get alerted when CVE-2026-32971 or the next vulnerability affects your stack