What’s Vulnerable › Vulnerabilities
CVE-2026-32973: OpenClaw < 2026.3.11 - Exec Allowlist Pattern Overmatch via POSIX Path Normalization
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-29 · updated 2026-06-17
- Weakness: CWE-625
Description
OpenClaw before 2026.3.11 contains an exec allowlist bypass vulnerability where matchesExecAllowlistPattern improperly normalizes patterns with lowercasing and glob matching that overmatches on POSIX paths. Attackers can exploit the ? wildcard matching across path segments to execute commands or paths not intended by operators.
Affected products
- OpenClaw: before 2026.3.11 — fixed in 2026.3.11
How to fix
Upgrade to a fixed version: OpenClaw 2026.3.11. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-f8r2-vg7x-gh8m
- https://www.vulncheck.com/advisories/openclaw-exec-allowlist-pattern-overmatch-via-posix-path-normalization
Get alerted when CVE-2026-32973 or the next vulnerability affects your stack