What’s Vulnerable › Vulnerabilities
CVE-2026-32990: Apache Tomcat: Fix for CVE-2025-66614 is incomplete
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-09 · updated 2026-10-26
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache Tomcat due to an incomplete fix of CVE-2025-66614. This issue affects Apache Tomcat: from 11.0.15 through 11.0.19, from 10.1.50 through 10.1.52, from 9.0.113 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.
Affected products
- Apache Tomcat: from 9.0.113 before 9.0.116; from 10.1.50 before 10.1.53; from 11.0.15 before 11.0.20 — fixed in 9.0.116, 10.1.53, 11.0.20
How to fix
Upgrade to a fixed version: Apache Tomcat 9.0.116, 10.1.53, 11.0.20. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-32990 or the next vulnerability affects your stack