What’s Vulnerable › Vulnerabilities

CVE-2026-33001

Description

Jenkins 2.554 and earlier, LTS 2.541.2 and earlier does not safely handle symbolic links during the extraction of .tar and .tar.gz archives, allowing crafted archives to write files to arbitrary locations on the filesystem, restricted only by file system access permissions of the user running Jenkins. This can be exploited to deploy malicious scripts or plugins on the controller by attackers with Item/Configure permission, or able to control agent processes.

Affected products

How to fix

Upgrade to a fixed version: Jenkins 2.541.3, 2.555. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-33001 or the next vulnerability affects your stack