What’s Vulnerable › Vulnerabilities
CVE-2026-33019: libsixel: Integer overflow leads to Out-of-bounds Read in img2sixel
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-14 · updated 2026-07-25
- Weakness: CWE-125
Description
libsixel is a SIXEL encoder/decoder implementation derived from kmiya's sixel. Versions 1.8.7 and prior contain an integer overflow leading to an out-of-bounds heap read in the --crop option handling of img2sixel, where positive coordinates up to INT_MAX are accepted without overflow-safe bounds checking. In sixel_encoder_do_clip(), the expression clip_w + clip_x overflows to a large negative value when clip_x is INT_MAX, causing the bounds guard to be skipped entirely, and the unclamped coordinate is passed through sixel_frame_clip() to clip(), which computes a source pointer far beyond the image buffer and passes it to memmove(). An attacker supplying a specially crafted crop argument with any valid image can trigger an out-of-bounds read in the heap, resulting in a reliable crash and potential information disclosure. This issue has been fixed in version 1.8.7-r1.
Affected products
- saitoha libsixel: before 1.8.7-r1 — fixed in 1.8.7-r1
How to fix
Upgrade to a fixed version: saitoha libsixel 1.8.7-r1. Check the vendor advisory for mitigations.
References
- https://github.com/saitoha/libsixel/releases/tag/v1.8.7-r1
- https://github.com/saitoha/libsixel/security/advisories/GHSA-c854-ffg9-g72c
- https://github.com/saitoha/libsixel/security/advisories/GHSA-c854-ffg9-g72c
Get alerted when CVE-2026-33019 or the next vulnerability affects your stack