What’s Vulnerable › Vulnerabilities
CVE-2026-33026: nginx-ui Backup Restore Allows Tampering with Encrypted Backups
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-30 · updated 2026-06-17
- Weakness: CWE-312
Description
Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.4, the nginx-ui backup restore mechanism allows attackers to tamper with encrypted backup archives and inject malicious configuration during restoration. This issue has been patched in version 2.3.4.
Affected products
- 0xJacky nginx-ui: before 2.3.4 — fixed in 2.3.4
How to fix
Upgrade to a fixed version: 0xJacky nginx-ui 2.3.4. Check the vendor advisory for mitigations.
References
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.3.4
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-fhh2-gg7w-gwpq
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-fhh2-gg7w-gwpq
Get alerted when CVE-2026-33026 or the next vulnerability affects your stack