What’s Vulnerable › Vulnerabilities
CVE-2026-33027: Nginx UI: Improper Path Validation Allows Recursive Deletion of the Nginx Configuration Directory
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-30 · updated 2026-06-17
- Weakness: CWE-22
Description
Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.4, the nginx-ui configuration improperly handles URL-encoded traversal sequences. When specially crafted paths are supplied, the backend resolves them to the base Nginx configuration directory and executes the operation on the base directory (/etc/nginx). In particular, this allows an authenticated user to remove the entire /etc/nginx directory, resulting in a partial Denial of Service. This issue has been patched in version 2.3.4.
Affected products
- 0xJacky nginx-ui: before 2.3.4 — fixed in 2.3.4
How to fix
Upgrade to a fixed version: 0xJacky nginx-ui 2.3.4. Check the vendor advisory for mitigations.
References
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.3.4
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-m8p8-53vf-8357
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-m8p8-53vf-8357
Get alerted when CVE-2026-33027 or the next vulnerability affects your stack