What’s Vulnerable › Vulnerabilities
CVE-2026-33028: Nginx UI: Race Condition Leads to Persistent Data Corruption and Service Collapse
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-30 · updated 2026-06-17
- Weakness: CWE-362
Description
Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.4, the nginx-ui application is vulnerable to a Race Condition. Due to the complete absence of synchronization mechanisms (Mutex) and non-atomic file writes, concurrent requests lead to the severe corruption of the primary configuration file (app.ini). This vulnerability results in a persistent Denial of Service (DoS) and introduces a non-deterministic path for Remote Code Execution (RCE) through configuration cross-contamination. This issue has been patched in version 2.3.4.
Affected products
- 0xJacky nginx-ui: before 2.3.4 — fixed in 2.3.4
- Uozi Cosy: before 1.30.1 — fixed in 1.30.1
How to fix
Upgrade to a fixed version: 0xJacky nginx-ui 2.3.4; Uozi Cosy 1.30.1. Check the vendor advisory for mitigations.
References
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.3.4
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-m468-xcm6-fxg4
Get alerted when CVE-2026-33028 or the next vulnerability affects your stack