What’s Vulnerable › Vulnerabilities
CVE-2026-3304: Multer vulnerable to Denial of Service via incomplete cleanup
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-27 · updated 2026-07-15
- Weakness: CWE-459
Description
Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing resource exhaustion. Users should upgrade to version 2.1.0 to receive a patch. No known workarounds are available.
Affected products
- multer: before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: multer 2.1.0. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/expressjs/multer/commit/739919097dde3921ec31b930e4b9025036fa74ee
- https://github.com/expressjs/multer/security/advisories/GHSA-xf7r-hgr6-v32p
- https://www.cve.org/CVERecord?id=CVE-2026-3304
- https://access.redhat.com/errata/RHSA-2026:6174
- https://access.redhat.com/errata/RHSA-2026:6802
- https://access.redhat.com/security/cve/CVE-2026-3304
- https://bugzilla.redhat.com/show_bug.cgi?id=2443353
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-3304.json
Get alerted when CVE-2026-3304 or the next vulnerability affects your stack