What’s Vulnerable › Vulnerabilities
CVE-2026-33073: discourse-subscriptions plugin leaking stripe API key in multisite environment
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-07-24
- Weakness: CWE-200
Description
Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, the discourse-subscriptions plugin leaks stripe API keys across sites in a multisite cluster resulting in the potential for stripe related information to be leaked across sites within the same multisite cluster. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.
Affected products
- discourse: from 2026.1.0 before 2026.1.3; from 2026.2.0 before 2026.2.2; 2026.3.0 — fixed in 2026.1.3, 2026.2.2
How to fix
Upgrade to a fixed version: discourse 2026.1.3, 2026.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/c34f2aac8dcd1ae2886fa84256f607bc003f9d80
- https://github.com/discourse/discourse/security/advisories/GHSA-f866-8fcp-fgvv
Get alerted when CVE-2026-33073 or the next vulnerability affects your stack