What’s Vulnerable › Vulnerabilities
CVE-2026-33074: Discourse: Vulnerability in discourse-subscriptions plugin allowing users to self-grant to higher tier subscriptions
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-07-24
- Weakness: CWE-269
Description
Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, a user may be able to purchase a lower tier subscription but grant themselves the benefits that comes along with a higher tier subscription. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.
Affected products
- discourse: from 2026.1.0 before 2026.1.3; from 2026.2.0 before 2026.2.2; 2026.3.0 — fixed in 2026.1.3, 2026.2.2
How to fix
Upgrade to a fixed version: discourse 2026.1.3, 2026.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/c34f2aac8dcd1ae2886fa84256f607bc003f9d80
- https://github.com/discourse/discourse/security/advisories/GHSA-9vg5-mp49-xghh
Get alerted when CVE-2026-33074 or the next vulnerability affects your stack