What’s Vulnerable › Vulnerabilities
CVE-2026-33077: Roxy-WI has an arbitrary file read vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-24 · updated 2026-06-17
- Weakness: CWE-22
Description
Roxy-WI is a web interface for managing Haproxy, Nginx, Apache and Keepalived servers. Prior to version 8.2.6.4, the oldconfig parameter in the haproxy_section_save interface has an arbitrary file read vulnerability. Version 8.2.6.4 fixes the issue.
Affected products
- roxy-wi: before 8.2.6.4 — fixed in 8.2.6.4
How to fix
Upgrade to a fixed version: roxy-wi 8.2.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/roxy-wi/roxy-wi/commit/aecc7971959092fa93e93531f1ffcde33524b031
- https://github.com/roxy-wi/roxy-wi/security/advisories/GHSA-c799-4ww6-q93w
- https://github.com/roxy-wi/roxy-wi/security/advisories/GHSA-c799-4ww6-q93w
Get alerted when CVE-2026-33077 or the next vulnerability affects your stack