What’s Vulnerable › Vulnerabilities
CVE-2026-33078: Roxy-WI has SQL Injection in haproxy_section_save Endpoint via Unsanitized server_ip Parameter
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-24 · updated 2026-06-17
- Weakness: CWE-89
Description
Roxy-WI is a web interface for managing Haproxy, Nginx, Apache and Keepalived servers. Versions prior to 8.2.6.4 have a SQL injection vulnerability in the haproxy_section_save function in app/routes/config/routes.py. The server_ip parameter, sourced from the URL path, is passed unsanitized through multiple function calls and ultimately interpolated into a SQL query string using Python string formatting, allowing attackers to execute arbitrary SQL commands. Version 8.2.6.4 fixes the issue.
Affected products
- roxy-wi: before 8.2.6.4 — fixed in 8.2.6.4
How to fix
Upgrade to a fixed version: roxy-wi 8.2.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/roxy-wi/roxy-wi/commit/aecc7971959092fa93e93531f1ffcde33524b031
- https://github.com/roxy-wi/roxy-wi/security/advisories/GHSA-jmj9-2c4q-849j
- https://github.com/roxy-wi/roxy-wi/security/advisories/GHSA-jmj9-2c4q-849j
Get alerted when CVE-2026-33078 or the next vulnerability affects your stack