What’s Vulnerable › Vulnerabilities
CVE-2026-33080: Filament: Unvalidated Range and Values summarizer values can be used for XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Filament is a collection of full-stack components for accelerated Laravel development. Versions 4.0.0 through 4.8.4 and 5.0.0 through 5.3.4 have two Filament Table summarizers (Range, Values) that render raw database values without escaping HTML. If there is a lack of validation for the data in the columns that use these summarizers, an attacker could plant malicious HTML / JavaScript and achieve stored XSS that executes for users who view the table with those summarizers. This issue has been patched in versions 4.8.5 and 5.3.5.
Affected products
- filamentphp filament: from 4.0.0 before 4.8.5; from 5.0.0 before 5.3.5 — fixed in 4.8.5, 5.3.5
How to fix
Upgrade to a fixed version: filamentphp filament 4.8.5, 5.3.5. Check the vendor advisory for mitigations.
References
- https://github.com/filamentphp/filament/commit/efa041aeeb4b1a99acd48aaa05584993c926d1ed
- https://github.com/filamentphp/filament/releases/tag/v4.8.5
- https://github.com/filamentphp/filament/releases/tag/v5.3.5
- https://github.com/filamentphp/filament/security/advisories/GHSA-vv3x-j2x5-36jc
Get alerted when CVE-2026-33080 or the next vulnerability affects your stack