What’s Vulnerable › Vulnerabilities
CVE-2026-33154: dynaconf Affected by Remote Code Execution (RCE) via Insecure Template Evaluation in @jinja Resolver
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-20 · updated 2026-06-17
- Weakness: CWE-94
Description
dynaconf is a configuration management tool for Python. Prior to version 3.2.13, Dynaconf is vulnerable to Server-Side Template Injection (SSTI) due to unsafe template evaluation in the @Jinja resolver. When the jinja2 package is installed, Dynaconf evaluates template expressions embedded in configuration values without a sandboxed environment. This issue has been patched in version 3.2.13.
Affected products
- dynaconf: before 3.2.13 — fixed in 3.2.13
How to fix
Upgrade to a fixed version: dynaconf 3.2.13. Check the vendor advisory for mitigations.
References
- https://github.com/dynaconf/dynaconf/commit/2fbb45ee36b8c0caa5b924fe19f3c1a5e8603fa7
- https://github.com/dynaconf/dynaconf/releases/tag/3.2.13
- https://github.com/dynaconf/dynaconf/security/advisories/GHSA-pxrr-hq57-q35p
Get alerted when CVE-2026-33154 or the next vulnerability affects your stack