What’s Vulnerable › Vulnerabilities
CVE-2026-33159: Craft CMS: Unauthenticated users could execute project configuration sync operations that should be restricted trusted users
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-24 · updated 2026-06-17
- Weakness: CWE-306
Description
Craft CMS is a content management system (CMS). From version 4.0.0-RC1 to before version 4.17.8 and from version 5.0.0-RC1 to before version 5.9.14, guest users can access Config Sync updater index, obtain signed data, and execute state-changing Config Sync actions (regenerate-yaml, apply-yaml-changes) without authentication. This issue has been patched in versions 4.17.8 and 5.9.14.
Affected products
- craftcms cms: from 4.0.0 (excl.) before 4.17.8; from 5.0.0 (excl.) before 5.9.14; 4.0.0, 4.0.0-rc1, 4.0.0-rc2, 4.0.0-rc3, 5.0.0, 5.0.0-rc1 — fixed in 4.17.8, 5.9.14
How to fix
Upgrade to a fixed version: craftcms cms 4.17.8, 5.9.14. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/commit/7f0ead833f7c2b91ae12003caad833479dd08592
- https://github.com/craftcms/cms/releases/tag/4.17.8
- https://github.com/craftcms/cms/releases/tag/5.9.14
- https://github.com/craftcms/cms/security/advisories/GHSA-6mrr-q3pj-h53w
Get alerted when CVE-2026-33159 or the next vulnerability affects your stack