What’s Vulnerable › Vulnerabilities
CVE-2026-33167: Rails has a possible XSS vulnerability in its Action Pack debug exceptions
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-23 · updated 2026-08-12
- Weakness: CWE-79
Description
Action Pack is a Rubygem for building web applications on the Rails framework. In versions on the 8.1 branch prior to 8.1.2.1, the debug exceptions page does not properly escape exception messages. A carefully crafted exception message could inject arbitrary HTML and JavaScript into the page, leading to XSS. This affects applications with detailed exception pages enabled (`config.consider_all_requests_local = true`), which is the default in development. Version 8.1.2.1 contains a patch.
Affected products
- Ruby on Rails: from 8.1.0 before 8.1.2.1 — fixed in 8.1.2.1
How to fix
Upgrade to a fixed version: Ruby on Rails 8.1.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/rails/rails/commit/6752711c8c31d79ba50d13af6a6698a3b85415e0
- https://github.com/rails/rails/releases/tag/v8.1.2.1
- https://github.com/rails/rails/security/advisories/GHSA-pgm4-439c-5jp6
Get alerted when CVE-2026-33167 or the next vulnerability affects your stack