What’s Vulnerable › Vulnerabilities

CVE-2026-33170: Rails Active Support has a possible XSS vulnerability in SafeBuffer#%

Description

Active Support is a toolkit of support libraries and Ruby core extensions extracted from the Rails framework. Prior to versions 8.1.2.1, 8.0.4.1, and 7.2.3.1, `SafeBuffer#%` does not propagate the `@html_unsafe` flag to the newly created buffer. If a `SafeBuffer` is mutated in place (e.g. via `gsub!`) and then formatted with `%` using untrusted arguments, the result incorrectly reports `html_safe? == true`, bypassing ERB auto-escaping and possibly leading to XSS. Versions 8.1.2.1, 8.0.4.1, and 7.2.3.1 contain a patch.

Affected products

How to fix

Upgrade to a fixed version: Ruby on Rails 7.2.3.1, 8.0.4.1, 8.1.2.1; Rubygems Activesupport 8.1.2.1, 8.0.4.1, 7.2.3.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-33170 or the next vulnerability affects your stack