What’s Vulnerable › Vulnerabilities
CVE-2026-33175: OAuthenticator: Authentication Bypass in Auth0OAuthenticator via Unverified Email Claims
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-03 · updated 2026-07-24
- Weakness: CWE-287
Description
OAuthenticator is software that allows OAuth2 identity providers to be plugged in and used with JupyterHub. Prior to version 17.4.0, an authentication bypass vulnerability in oauthenticator allows an attacker with an unverified email address on an Auth0 tenant to login to JupyterHub. When email is used as the usrname_claim, this gives users control over their username and the possibility of account takeover. This issue has been patched in version 17.4.0.
Affected products
- jupyterhub oauthenticator: before 17.4.0 — fixed in 17.4.0
How to fix
Upgrade to a fixed version: jupyterhub oauthenticator 17.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/jupyterhub/oauthenticator/commit/f0c7002dc36e41efae0f674033cf7888a21d96f9
- https://github.com/jupyterhub/oauthenticator/releases/tag/17.4.0
- https://github.com/jupyterhub/oauthenticator/security/advisories/GHSA-rrvg-cxh4-qhrv
Get alerted when CVE-2026-33175 or the next vulnerability affects your stack