What’s Vulnerable › Vulnerabilities
CVE-2026-33214: Weblate has improper access control for the translation memory API
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-15 · updated 2026-10-26
- Weakness: CWE-862
Description
Weblate is a web based localization tool. In versions prior to 5.17, the translation memory API exposed unintended endpoints, which in turn didn't enforce proper access control. This issue has been fixed in version 5.17. If users are unable to update immediately, they can work around this issue by blocking access to /api/memory/ in the HTTP server, which removes access to this feature.
Affected products
- WeblateOrg weblate: before 5.17 — fixed in 5.17
How to fix
Upgrade to a fixed version: WeblateOrg weblate 5.17. Check the vendor advisory for mitigations.
References
- https://github.com/WeblateOrg/weblate/pull/18513
- https://github.com/WeblateOrg/weblate/security/advisories/GHSA-mpf5-3vph-q75r
Get alerted when CVE-2026-33214 or the next vulnerability affects your stack