What’s Vulnerable › Vulnerabilities
CVE-2026-33218: NATS has pre-auth server panic via leafnode handling
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-25 · updated 2026-09-09
- Weakness: CWE-20
Description
NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Prior to versions 2.11.15 and 2.12.6, a client which can connect to the leafnode port can crash the nats-server with a certain malformed message pre-authentication. Versions 2.11.15 and 2.12.6 contain a fix. As a workaround, disable leafnode support if not needed or restrict network connections to the leafnode port, if plausible without compromising the service offered.
Affected products
- nats-io nats-server: before 2.11.15; from 2.12.0 before 2.12.6 — fixed in 2.11.15, 2.12.6
How to fix
Upgrade to a fixed version: nats-io nats-server 2.11.15, 2.12.6. Check the vendor advisory for mitigations.
References
- https://advisories.nats.io/CVE/secnote-2026-10.txt
- https://github.com/nats-io/nats-server/security/advisories/GHSA-vprv-35vv-q339
- https://access.redhat.com/errata/RHSA-2026:21769
- https://access.redhat.com/errata/RHSA-2026:22347
- https://access.redhat.com/errata/RHSA-2026:23345
- https://access.redhat.com/security/cve/CVE-2026-33218
- https://bugzilla.redhat.com/show_bug.cgi?id=2451450
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-33218.json
Get alerted when CVE-2026-33218 or the next vulnerability affects your stack