What’s Vulnerable › Vulnerabilities
CVE-2026-33227: Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ Web, Apache ActiveMQ: Improper Limitation of a Pathname to a Restricted Classpath Directory
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-07 · updated 2026-10-26
- Weakness: CWE-22
Description
Improper validation and restriction of a classpath path name vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ Web, Apache ActiveMQ. In two instances (when creating a Stomp consumer and also browsing messages in the Web console) an authenticated user provided "key" value could be constructed to traverse the classpath due to path concatenation. As a result, the application is exposed to a classpath path resource loading vulnerability that could potentially be chained together with another attack to lead to exploit. This issue affects Apache ActiveMQ Client: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Broker: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ All: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Web: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ: before 5.19.3, from 6.0.0 before 6.2.2. Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue. Note: 5.19.3 and 6.2.2 also fix this issue, but that is limited to non-Windows environments due to a path separator resolution bug fixed in 5.19.4 and 6.2.3.
Affected products
- Apache ActiveMQ: before 5.19.3; from 6.0.0 before 6.2.2 — fixed in 5.19.3, 6.2.2
- Apache Activemq Broker: before 5.19.3; from 6.0.0 before 6.2.2 — fixed in 5.19.3, 6.2.2
- Apache Activemq Web: before 5.19.3; from 6.0.0 before 6.2.2 — fixed in 5.19.3, 6.2.2
How to fix
Upgrade to a fixed version: Apache ActiveMQ 5.19.3, 6.2.2; Apache Activemq Broker 5.19.3, 6.2.2; Apache Activemq Web 5.19.3, 6.2.2. Check the vendor advisory for mitigations.
References
- https://activemq.apache.org/security-advisories.data/CVE-2026-33227-announcement.txt
- http://www.openwall.com/lists/oss-security/2026/04/06/4
Get alerted when CVE-2026-33227 or the next vulnerability affects your stack