What’s Vulnerable › Vulnerabilities
CVE-2026-33229: XWiki Platform affected by remote code execution with script right through unprotected Velocity scripting API
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-08 · updated 2026-07-24
- Weakness: CWE-862
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Prior to 17.4.8 and 17.10.1, an improperly protected scripting API allows any user with script right to bypass the sandboxing of the Velocity scripting API and execute, e.g., arbitrary Python scripts, allowing full access to the XWiki instance and thereby compromising the confidentiality, integrity and availability of the whole instance. Note that script right already constitutes a high level of access that we don't recommend giving to untrusted users. This vulnerability is fixed in 17.4.8 and 17.10.1.
Affected products
- xwiki-platform: from 17.0.0 before 17.4.8; from 17.5.0 before 17.10.1 — fixed in 17.10.1, 17.4.8
How to fix
Upgrade to a fixed version: xwiki-platform 17.10.1, 17.4.8. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/9fe84da66184c05953df9466cf3a4acd15a46e63
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-h259-74h5-4rh9
- https://jira.xwiki.org/browse/XWIKI-23698
- https://jira.xwiki.org/browse/XWIKI-23702
Get alerted when CVE-2026-33229 or the next vulnerability affects your stack