What’s Vulnerable › Vulnerabilities
CVE-2026-33281: Ella Core panics on invalid PDU Session IDs in NGAP messages
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-24 · updated 2026-06-17
- Weakness: CWE-129
Description
Ella Core is a 5G core designed for private networks. Versions prior to 1.6.0 panic when processing NGAP messages with invalid PDU Session IDs outside of 1-15. An attacker able to send crafted NGAP messages to Ella Core can crash the process, causing service disruption for all connected subscribers. No authentication is required. Version 1.6.0 added PDU Session ID validations during NGAP message handling.
Affected products
- ellanetworks core: before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: ellanetworks core 1.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-33281 or the next vulnerability affects your stack