What’s Vulnerable › Vulnerabilities
CVE-2026-33284: GlobalLeaks has insufficient URL validation in user support API
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-27 · updated 2026-10-26
- Weakness: CWE-20
Description
GlobaLeaks is free and open-source whistleblowing software. Prior to version 5.0.89, the /api/support endpoint of GlobaLeaks performs minimal validation on user-submitted support requests. As a result, arbitrary URLs can be included in support emails sent to administrators. Version 5.0.89 patches the issue.
Affected products
- globaleaks-whistleblowing-software: before 5.0.89 — fixed in 5.0.89
How to fix
Upgrade to a fixed version: globaleaks-whistleblowing-software 5.0.89. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-33284 or the next vulnerability affects your stack