What’s Vulnerable › Vulnerabilities
CVE-2026-33303: OpenEMR Vulnerable to Stored XSS via Unescaped portal_login_username in Credential Print View
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-79
Description
OpenEMR is a free and open source electronic health records and medical practice management application. Versions prior to 8.0.0.2 are vulnerable to stored cross-site scripting (XSS) via unescaped `portal_login_username` in the portal credential print view. A patient portal user can set their login username to an XSS payload, which then executes in a clinic staff member's browser when they open the "Create Portal Login" page for that patient. This crosses from the patient session context into the staff/admin session context. Version 8.0.0.2 fixes the issue.
Affected products
- openemr: before 8.0.0.2 — fixed in 8.0.0.2
How to fix
Upgrade to a fixed version: openemr 8.0.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/c32139b5144b1c704015221520ad2f931e25f10d
- https://github.com/openemr/openemr/security/advisories/GHSA-cp37-pmfx-5mhm
Get alerted when CVE-2026-33303 or the next vulnerability affects your stack