What’s Vulnerable › Vulnerabilities
CVE-2026-33311: @dicebear/core and @dicebear/initials Vulnerable to SVG Injection via Unsanitized Options
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-24 · updated 2026-06-17
- Weakness: CWE-79
Description
DiceBear is an avatar library for designers and developers. Starting in version 5.0.0 and prior to versions 5.4.4, 6.1.4, 7.1.4, 8.0.3, and 9.4.1, SVG attribute values derived from user-supplied options (`backgroundColor`, `fontFamily`, `textColor`) were not XML-escaped before interpolation into SVG output. This could allow Cross-Site Scripting (XSS) when applications pass untrusted input to `createAvatar()` and serve the resulting SVG inline or with `Content-Type: image/svg+xml`. Starting in versions 5.4.4, 6.1.4, 7.1.4, 8.0.3, and 9.4.1, all affected SVG attribute values are properly escaped using XML entity encoding. Users should upgrade to the listed patched versions. Some mitigating factors limit vulnerability. Applications that validate input against the library's JSON Schema before passing it to `createAvatar()` are not affected. The DiceBear CLI validates input via AJV and was not vulnerable. Exploitation requires that an application passes untrusted, unvalidated external input directly as option values.
Affected products
- dicebear: from 5.0.0 before 5.4.4; from 6.0.0 before 6.1.4; from 7.0.0 before 7.1.4; from 8.0.0 before 8.0.3; from 9.0.0 before 9.4.1 — fixed in 5.4.4, 6.1.4, 7.1.4, 8.0.3, 9.4.1
How to fix
Upgrade to a fixed version: dicebear 5.4.4, 6.1.4, 7.1.4, 8.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-33311 or the next vulnerability affects your stack