What’s Vulnerable › Vulnerabilities
CVE-2026-33327: Possible integer overflow leading to potential heap-based buffer overflow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-08-19
- Weakness: CWE-190
Description
libvips is a fast image processing library with low memory needs. The `vipsload` operation in versions before and including 8.18.0 could incorrectly determine image dimensions leading to an integer overflow and a subsequent heap-based buffer overflow. This has been patched in version 8.18.1.
Affected products
- libvips: before 8.18.1 — fixed in 8.18.1
How to fix
Upgrade to a fixed version: libvips 8.18.1. Check the vendor advisory for mitigations.
References
- https://github.com/libvips/libvips/commit/61e71c13328ed72d0a530dffc19b9b225072bdf9
- https://github.com/libvips/libvips/pull/4934
- https://github.com/libvips/libvips/security/advisories/GHSA-2fcj-gj27-279x
Get alerted when CVE-2026-33327 or the next vulnerability affects your stack